
MAGNET4WATER StormNET SAMPLE PROJECT 1 

TechSmith Site Stormwater System Design 

The following student exercise considers a hypothetical stormwater system design and input parameters, 

although the site on which it is based is real. The design aspects specified in this project are for educational 

purposes only and do necessarily reflect real-world conditions.  

SUMMARY 

You are hired to analyze (and improve upon) a design for a stormwater management system for the 

TechSmith headquarters located on the Michigan State University campus in East Lansing, Michigan 

(Figure 1).  Stormwater captured by buildings, sidewalks and other paved areas is to be conveyed to an on-

site holding pond through a proposed system of junctions (manholes) and conduits (pipes). Using a 

sophisticated simulation software – MAGNET4WATER StormNET - you will design (and then refine) the 

pipes (including their sizes, slopes, and roughness) and a holding pond (total volume, dimensions, and 

outflow control structures). You will also assess potential impact of Low Impact Development (LID) 

controls or other green infrastructure integrated into the system.   

 

 



Figure 1 – TechSmith site location on the campus of Michigan State University. 

BACKGROUND 

Michigan State University continues to implement its vision of redeveloping Spartan Village – a 140-acre 

residential area - into a technology and innovation campus.  A new headquarters for Tech-Smith, a software 

development company, was recently constructed on approximately 10 acres of land and consists of 

buildings, outdoor patios, sidewalks, small green spaces, and parking areas.  

Under natural conditions, storm water slowly drains from west to east, following the gentle slope of the 

land within the proposed parcel area. A storm-water system design subdivides the property into 20 lots (or 

subcatchments): 3 “building” lots in the south (consisting of headquarter buildings, sidewalks, and outdoor 

patios); 13 parking areas; 3 green spaces, and the main entrance walkway (see Figure 2). It is proposed that 

storm water collected in the various subcatchments be routed to an on-site detention pond through an 

underground storm-sewer system consisting of conduits (pipes) and junctions (manholes) (see Figure 3). 

Flow is attenuated by a stormwater detention pond before being released to an existing downstream sewer 

line.  

(Again, the layout and design parameters presented here do not necessarily reflect real world conditions.)    

 

Figure 2 – Runoff routing design of the storm-sewer system. 



 

Figure 3 – Subsurface conveyance (pipe network) design of the storm-sewer system. 

 

OBJECTIVE 

Your objective is to determine the feasibility of the proposed storm-sewer system design.  The major steps 

of the project involved include: 

1. Initial design – create a “digital twin” of the storm-sewer design that includes the various 

subcatchments, the subsurface conveyance system, the detention pond (and its control structures), 

and the system hookup to the existing sewer service line.  

2. Storm sewer design refinement - perform simulation-based iterative design activities to optimize 

design parameters (pipe sizes and slopes) to ensure compliance to code  

3. Holding pond design refinement – perform simulation-based iterative design to optimize pond size 

and outflow structure so that outflow is less and or equal to that under natural conditions for a 24 

hr., 100yr storm.  

4. (HONORS Option) Green infrastructure design – assess potential impact of additional Low Impact 

Development (LID) controls integrated into the storm-sewer system. 

Further instructions and retails regarding each major step are provided in the sections below. Detailed tables 

and figures needed for your analysis are included.  



DELIVERABLE 

Please assemble a professional-level technical report, written following the guidelines used in CE321.  

Major components include: 

• Title page 

• Executive Summary 

• Table of Contents 

• Introduction 

• Methods 

• Results and Discussion 

• Conclusions 

• Appendix (Additional Supporting Information) 

Make sure to document your entire procedure and list all assumptions.  Answer all questions and include 

all items mentioned in the sections.  Make sure your report is professional and well written.  It must be 

typed using a word processor.  All illustrations, graphs, figures, and equations must be computer generated. 

Grammar, spelling, sentence structure, and completeness will all factor into your grade in addition to your 

ability to solve the problem. 

Keep in Mind:  

The problem has been formulated such that all the data you need is contained in this report.  When looking 

at your results, keep in mind if they seem reasonable.  This will help tell you if you are on the right track.  

Make sure to show and explain how you solved the problem.   

 

DETAILED INSTRUCTIONS  

1. System Design and Model Setup 

Storm water from largely impervious areas is drained to or treated by several LIDs (bioretention cells) 

before entering the stormwater drains. Flow in the stormwater drains is routed to and attenuated by a 

stormwater detention pond before being released to an existing downstream sewer line.  

 

A. Getting Started with StormNET 

The first step towards using StormNET for site design and analysis is to create a free StormNET user 

account. 

• Open a browser an navigate to: https://www.magnet4water.org/stormnet/    

• Along the top header menus of the StormNET modeling environment, click: ‘Sign Up’ 

 Then, go through the Quick Tutorial: 

• Along the top header menus of the StormNET modeling environment, click: ‘Tutorial’.  

• Click: Quick Tutorial 2 – Georeferenced Model. This opens a PDF explaining, step-by-step with 

an example, how to zoom into any location and create a georeferenced stormwater model with 

StormNET.  

https://www.magnet4water.org/stormnet/


• Quick Tutorial 1 – Synthetic Model may also be helpful to go through to learn the interface system 

and how to use different model objects and options/settings.  

 

B. Creating the ‘Initial’ StormNET Model 

Use what you learned from going through the Quick Tutorials to draw the network and assign object 

attributes. 

B1: Draw the parking lot, building, and green space subcatchments and assign attributes (in Subcatchment 

Editor interface): 

• Use the search bar in the StormNET mapping environment to zoom to ‘TechSmith’ in East Lansing, 

Michigan, USA.  

• Use Figure 2 as a guide for subcatchment positioning / size / extent. 

• The area of the subcatchment is automatically assigned based on the map (you can overwrite the 

computed value, if needed) 

• Compute and assign a characteristic width based on: Characteristic width = (Subcatchment 

area)/(Characteristic length).  The mean characteristic length of the subcatchments . 

• Assign slope to each subcatchment. The average design slope is 0.5% 

• Impervious and Pervious Areas 

o For subcatchments with building/sidewalks/etc., assume 90% coverage of impervious 

material (10% pervious) 

o For subcatchments with parking lots, assume 100% coverage of impervious material (0% 

pervious) 

o For subcatchments with green spaces, assume 0% coverage of impervious material (100% 

pervious) 

• Manning’s Roughness: 

o Mannings roughness (N) for impervious areas of Building lots can be assigned as 0.015 

o For pervious areas of Building lots and green space, N can be assigned as 0.1.  

o For Parking lots, use 0.01.  

o Under Subcatchment Editor, N-Imper and N-Perv is Mannings roughness for impervious  

and pervious areas, respectively;  

• Add a building height to the Building lots for 3D CAD visualization 

o Subcatchment Editor > Visualization Parameters > Enter ‘100ft’ for Height 

o Optional: Choose a Image for Building top or an image for Building Side 

o Later, using Add DEM, the elevations of the subcatchment vertices and centroid will be 

automatically calculated 

• All other default StormNET subcatchment parameters can be used in all subcatchments.  

• Click the ‘?’ button for explanations of all Subcatchment parameters. 

B2: Draw the bioretention cell (Low Impact Design) subcatchments and assign attributes: 

• Again use average design slope of 0.5% 

• Mean characteristic length of bioretention cell subcatchments is 25ft 

• Make 100% of subcatchment area assigned as a BioRETCell (Bioretention cell) 

o Subcatchment Editor > Low Impact Development Tab > Add LID Control … 

• Use the default parameters for BioRETCell (can be refined later, see below) 

 



B3: Draw the holding pond and assign attributes: 

• Add a trapezoid-shaped Storage Unit in the location indicated in Figures 2 and 3 

o Click: Hydraulics > Storage Units > Select SU Type > Trapezoid > Start Drawing  

• Use the default Invert El and Max. Depth. Invert El will be updated from land surface elevations in 

the next step. Max Depth will be optimized during iterative design (see below) 

o NOTE: The top of the pond should not be higher than the land elevation! 

• Open the Curve Editor, Edit existing > Storage > Trapezoid.  This interface takes defined input 

parameters and intelligently creates a range of depths (given a Max Depth and NH, the number of 

discrete depth values) and automatically calculates the surface area and volume of the pond at 

different depths. Calculation of routing and storage in the pond uses the generated relationship (or 

curve) between depth, area, and volume during simulation.  

 

B4: Add an Orifice and assign attributes: 

The outlet structure will consist of an orifice at the bottom of the holding pond, and emergency spillway 

through a weir so that pond depth does not exceed certain threshold depth. 

• The orifice should be placed at the bottom of the holding pond. 

• The orifice should start at the detention pond and end at junction just to the right (east) of the pond 

 

B5: Add a Weir and assign attributes:  

• The weir should be placed near the top of the holding pond, to be used in case of emergency 

overfilling of the holding pond. This is accomplished by using a non-zero Inlet Offset (height of 

weir opening from invert elevation of upstream node). 

• The weir should start at the holding pond and end at junction just to the right (east) of the pond 

• You can start by using the default weir type: TRANSVERSE; but consider experimenting with 

different types/shapes for your design purposes (see more below).  

 

B6: Add a system Outfall  

• StormNET requires that all models have a system outlet (Outfall) to perform simulation. Add one 

to the map in the location depicted in Figure 2.  

• Use a FREE condition for the outfall.  

 

B7: Draw the Junctions and assign attributes (add DEM): 

• Draw the various junctions at the approximate locations indicated in Figure 2.  

• Note that a junction is needed just after the detention pond and just before system Outfall  

• Assign invert elevations based on land surface elevations and assumed max. depths 

o Click: Simulate > Add DEM …wait for prompt to declare ‘DEM Retrieved 

Successfully…” 

• All other defaults for StormNET junction parameters can be used.  

 



B8: Link the Subcatchments to appropriate Subcatchment Outlets: 

• This is done one-by-one for each subcatchment. Use the Runoff Outlet annotations in Figure 2 as 

a guide.  

• Note that most subcatchments outlet to another subcatchment; for example, most parking lot 

subcatchments outlet to a bioretention cell subcatchment) 

• Green space subcatchments and building subcatchments should like to a manhole (junction) 

o This design assumes runoff from the building roofs is routed to the ground-level manhole 

just near the building (implicitly) through downspouts.  

• See the referenced Quick Tutorials for examples / details of linking subcatchments to junctions (or 

other network objects).  

 

B9: Draw Conduits and assign attributes: 

• When drawing, always remember: conduits should start at the upstream node and end at the 

downstream node. 

• The length of the conduit is automatically assigned based on the map (you can overwrite the 

computed value, if needed). 

• Assume initially that all people are made of concrete (n=0.01) and are circular in shape.  

• Use the default Max Depth (diameter) for each pipe; later, the pipe size will be optimized through 

iterative design  

• You can use the default values for all other parameters in the Conduit editor. Later, you may want 

to apply non-zero Inlet and/or Outlet Offsets (or height of the conduit invert above the upstream 

or downstream node invert elevation). By default, conduits connect to the bottom of junctions.  

• Remember to click the ‘?’ button for explanations of all conduit parameters. 

 

B10: Add A Rain Gage and define the design storm event: 

• Click: Hydrology > Rain Gages 

• In the Time Series editor, assign a 24-hr, 100-yr storm event to your rain gage 

• The SCS Type II curve is available as an existing Time Series in StormNET 

• Don’t forget to apply a multiplier to create a rain event with a total depth equal to the design depth 

see the Table below).  

 

 

 

 

 

 

 

 



Table  – Intensity-duration-frequency estimates for mid-Michigan climatic zone. Note that the values 

inside the table are the depth of rainfall (e.g., for 10-yr, 15-min duration storm, a depth of 0.89 inches of 

rain is added to the landscape).  

 

 

B11: Set up Simulation Options: 

• Click: Options > Dates 

• Assign a 30-hour simulation time (Options > Dates) with a 15-minute (or shorter) reporting time 

(Options > Time Steps). Use a Routing Step of 30 seconds. 

• Make sure you are using the Dynamic Wave Routing Model (Options > General). 

B12: Run the Simulation and view/analyze the Results (including 3D CAD) 

• Pay particular attention to: 

o Velocity in the Conduits at different time-steps. 

o Potential flooding at the nodes at different time-steps. 

o Storage in the Holding Pond at different time steps. 

• The referenced Quick Tutorial includes examples of viewing plan view (map-based) results, time-

series results, results along a profile, 3D CAD system visualization, and a 3D plot-baseddepiction 

of the system with annotated/hover-based results.  

 

2.  Iterative Design Improvements and Performance Evaluation 

The next step (or fun part!) is: iterative design and optimization.  

In particular, you will optimize your design with respect to pipe sizes and pipe slopes to ensure 

compliance with the code (velocities are 1-3 m/s during the 24 hr., 100yr storm design storm). 

You will also optimize your pond design to ensure that your design is cost effective and complies with the 

code (the outflow must be less than or equal to that under natural condition; the outlet elevation is located 

such that a permanent storage is created for the first flush) using MAGNET StormNET.  

Local ordinance states that natural peak flows can be computed as: (0.15 cfs/acre)*(total acres) 

 



A. Performance Evaluation Criteria  

 

Consider following questions to iteratively optimize your design: 

• Does your model behave as expected in response to the design events? 

• In particular, does your storm water system behave as expected during the design storm?  

• Are there any pipes overloaded during the design storm causing on site surface flooding?  

• Are the storm sewers self-cleansing during the design storm when the rain intensity is at design 

intensity?  Are velocities within 3 to 10 ft/s (in all pipes, for all times)? 

• Does your storm water system behave as expected during the 100-year, 24 hour design storm 

(SCS Type II distribution)?  

• What is the flow rate in the pipe upstream of the detention pond in response to a 100-year storm 

event?  

• What is the flow rate in the pipe downstream of the detention pond in response to a 100-year 

storm event?  

• How does the water depth in the pond vary over time in response to a 100-year storm event? 

Take advantage of the powerful graphical capabilities to analyze / visualize your stormwater system: 

• MAP (plan) view at different times;  

• Profile view at different times, 

•  Time Series at different nodes/links; 

• 3D CAD  

•  3D plot 

Remember to use an iterative approach: design, simulate, visualize/analyze, make changes to your 

design, simulate, visualize/analyze, and so on. 

 

B. Storm-sewer Design Refinement 

You may need to change aspects of your model to ensure that velocities in all conduits are within 1-3 m/s 

throughout the storm event. Consider the following modifications. 

i) Changing the slope for one or more pipe(s): 

• In StormNET, this is accomplished by adjusting the Invert Elevations of nodes connected by a 

conduit 

• If you alter Invert Elevations, make sure Max Depth is adjusted accordingly (so that Invert 

Elevation + Max Depth always equals the land elevation). 



• You can also adjust the slope by using non-zero Inlet and/or Outlet Offsets.  

ii) Changing diameter for one or more pipe(s): 

• This is accomplished by changing the Max Depth in the Conduit Editor 

iii) if corrections to velocity are still needed, try changing roughness for one or more pipe(s): 

• Consult Manning Roughness tables for typical range of values depending on pipe material 

Also, refer to the slide from your class lecture regarding iterative sewer design (see attachment in 

Appendix). 

 

 

C. Holding Pond Design Refinement  

 

Evaluate the feasibility of connecting the holding pond to the existing MSU storm sewer line by 

modifying your StormNET model. More specifically, design the optimal pond size and outlet structure to 

ensure code compliance; for example, ensure that the outflow is less than is equal to that under natural 

conditions, and the depth is reasonable not a hazard. 

Remember, to use an iterative approach: design, simulate, visualize/analyze, make changes to your 

design, simulate, visualize/analyze, and so on.  

 

Experiment with different sizes of the orifice (heigh and width) such that outflow does not exceed peak 

natural flows 

• Also consider experimenting with the Discharge Coefficient. This parameter is a  dimensionless 

number used to characterize the flow and pressure loss behavior of and orifice. A lower coefficient 

means more loss (e.g., because of a sharp edge opening and/or the use of gratings) and vice versa.  

Consider experimenting with the Discharge Coefficient for the weir. 

• Remember, a freeboard of at least 1 ft is required. In other words, the top of  the holding pond 

should be at least 1ft above maximum water level in weir as water moves through it? Freeboard is 

a guard (or safety factor against overtopping by waves or unexpected rises in the water level. 

Resize your holding pond: 

• Open the Curve Editor, Edit existing > Storage > Trapezoid 

o Change the Trapezoid Parameters to resize the volume 

o Save the changes and close the Curve Editor.  

 

3. Additional Green Infrastructure Design (Honors Option) 

The term “green infrastructure” refers to a variety of practices that restore or mimic natural hydrological 

processes. While “gray” stormwater infrastructure moves stormwater away from the built environment, 

green infrastructure uses soils, vegetation, and other media to manage rainwater where it falls — through 

capture and evapotranspiration. 



The bioretention cells in your model are one example of green infrastructure.  

Use your modified StormNET model (modified holding pond with outflow structures, hookup to MSU 

sewer system, 24-hr,100-yr storm, etc.) to experiment with implementation of additional Low Impact 

Development (LID) controls and quantity their impact on the water quantity dynamics.  

Example LIDs that can be used in StormNET include: 

• Green roofs 

• Permeable pavement 

• Rain gardens 

• Vegetative swales 

• Infiltration trenches 

A. How to Add LID Controls 

StormNET includes a default LID and set of input parameters for each type. You can view the default LIDs 

under Hydrology in the Network Objects menu. Then select ‘Edit’ mode and choose a LID from the drop-

down list next to Control Name. Once a LID is selected, a small graphic and brief description of how the 

LID is modeled mathematically is provided, along with input parameter tables populated with default 

values. You can begin by using the default LID parameters, simulating, and analyzing the results, and then 

potentially experiment with different input values (within reasonable/plausible ranges) in an effort to 

maximize the impact of LID implementation. Make sure to click  the ‘?’ button for explanations of all LID 

input parameters. 

A LID control must be tied to one or more subcatchments to be used in your model. Open the Subcatchment 

editor for the subcatchment(s) of choice and go to the Low Impact Design tab. Then click Add Lid Control 

and select from the list of default lids. You can check the box next to ‘LID Occupies Full Subcatchment’ 

to apply the LID to 100% of the subcatchment area, or you can enter the Area of each unit and Number of 

units to have the LID occupy only a portion of the Subcatchment. (You can adjust area of each unit and/or 

number of units to attain a desired percentage of the subcatchment.) 

 

B. How to evaluate the impact of LID controls 

Impact from LIDS can examined through the flows in certain appropriate conduits or depths at certain nodes 

(e.g. your pond) with and without the LIDs. Use time-series, map-based or tabular depictions of model 

outputs for representative times in your 24-hr simulation.  

Remember to use an iterative approach: design, simulate, visualize/analyze, make changes to your design, 

simulate, visualize/analyze, and so on. 

 

 


