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Based on:
EPASWMM5 Tutorial with Images for SWMM 5.1.014

by Robert Dickinson

EPASWMM5 Tutorial with Images for SWMM 5.1.014  
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https://swmm5.org/2017/08/14/epa-swmm5-tutorial-with-images-for-swmm-5-1-012/


Browse to:

https://www.magnet4water.net/stormnet/

This site hosts the complete, integrated platform for storm water 
network modeling, analysis, and visualization.

The default interface environment is shown here. 

[Map Display / Working Environment]

[Objects 
and 
Options]

[Objects 
Attributes]

[Menu 
bar]

[Hover 
Map Status]

[Object Edit Tools]
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Create an account:

Sign Up [Menu Bar] 
> Complete Form

*The email you provide is used 
for resetting your password 
should you forget it. 



[View previously executed models and download model files for later use]

[Change email, User Type, Password, etc ]
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User Account:

User Account [Menu Bar] > …

Use this menu to change request a password 
reset, update your email, user type, etc., or 
view and/or download previously executed 
models for later use.



Add Subcatchments:

Hydrology > 
Subcatchments > Start 
Drawing 

The cursor turns into a blue circle, 
indicating ‘Drawing Mode’ is 
active. 

Use a single-click to add the first 
corner (vertex) of the 
subcatchment to the map display. 
Use additional single-clicks to add 
the other corners. 

A double-click “closes” the 
subcatchment.
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Repeat the steps on the previous slide to add the 2nd and 3rd subcatchments 
to the map display. 
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Edit Subcatchments:

Hydrology > 
Subcatchments > 
Edit Subcatchments

*A single-click on 
any map object also 
launches its Editor 
menu. 

Select the first subcatchment 
by its Subcat. ID/Name (1 for 
this example).

Default values are provided, 
but you can assign different 
values (next slide).
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The Area and Width in this subcatchment and all 
others should be set to 4 and 400, respectively. 

The percentage of impervious land cover should be 
set to 50%. 

Make sure the Subarea Routing is set to OUTLET and 
the Percent Routed is 100.
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Still within the Subcatchment Editor, navigate to the 
Infiltration/Pollutants/Land Uses tab. 

Select MODIFIED_GREEN_AMPT as the Infil. Method 
under Infiltration Data. 

Assign a Suction head of 3.5, a Conductivity of 0.5, and an 
Initial Deficit of 0.26

Click ‘Save’ to finalize changes before exiting the 
Subcatchment Editor (‘X’ button). 
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Add Junctions:

Hydraulics > Nodes > 
Junctions > Start Drawing

The cursor turns into a blue circle, 
indicating ‘Drawing Mode’ is active. 

Use a single-click to add the first junction 
to the map display.  Then use additional 
clicks to add the remaining junctions while 
in Drawing mode. 
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Edit Junctions:

Hydrology > Nodes > 
Junctions > Edit Junctions

Select the different junctions by their Junction ID (4-7 for this example) for attribute 
editing. 

The invert elevation (Invert El) in Junction 4 should be set to 700ft. The Max Depth 
should be set to four. 

Click ‘Save’ to finalize changes before selecting a new junction for editing: Junction 5, 
edit attributes, Save; Junction 6, edit, Save; and so on…

After updating and saving  all of the junctions, close the Junction Data Editor window 
(‘X’ button). 

Junction Invert El

4 96

5 90

6 93

7 88
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Add Conduits:

Hydraulics > Links > Conduits > Start 
Drawing

Again, the cursor turns into a blue circle, indicating 
‘Drawing Mode’ is active. 

Click once on Junction 4 to snap the conduit’s starting 
position to it. A blue line will extend from the node as you 
move the cursor. 

Double click on Junction 5 to snap the conduit’s ending 
position to it. 

*Once a link is started (i.e., snapped to the starting node), 
a single click only places a vertex for drawing purposes. 
The link is still “open” (not snapped to an end node).

**A link must have a starting and ending node. “Bad” 
pipes are deleted from the map display. 

***Conduits should be drawn from the upstream Junction 
to the downstream Junction (i.e., from higher to lower 
elevation). 
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Repeat the steps from the previous slide to add Conduit 2 
(connecting Junction 5 and 7) and Conduit 6 (J3 to J7). 
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Add Outfall:

Hydrology > Nodes > 
Outfalls > Start Drawing

The cursor turns into a blue circle, indicating 
‘Drawing Mode’ is active. 

Use a single-click to add the outfall to the 
map display.  
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Edit Outfall:

Hydraulics > Nodes > 
Outfalls > Edit Outfalls
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Select the outfall by its ID (8 for this example) for 
attribute editing. 

The invert elevation (Invert El) of the outfall should 
be 85. All other default values can be used.

Remember to Save before closing the Outfall Editor. 



Add Last Conduit:

Hydraulics > Links > Conduits > 
Start Drawing

Connect Junction 7 to the Outfall (ID=8) using a 
Conduit (Conduit ID=4). 
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Edit Conduits:

Hydraulics > Links > 
Conduits > Edit Conduit

Select the different Conduits by their Conduit ID (1-
4) in this example. 

Assign a Length of 400 for all Conduits. Assign a 
Max Depth of 1 for Conduits 1-3, and a Max Depth 
of 1.5 for Conduit 4, 

The Shape of the Conduits is circular (default 
shape). 

Remember to Save before closing the Outfall Editor. 



Add Subcatchment 
Outlets:
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Hydrology > Subcatchments > 
Edit Subcatchments

Select Subcatchment 1 and assign Junction as the 
Outlet node Type. Then select Junction 4 as the 
Outlet for Subcatchment 1. 

Save the changes, then change to Subcatchment 
2 to assign Junction 5 as the outlet. 
Subcatchment 3 uses Junction 6 as its outlet. 
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Save the changes, then change to Subcatchment 2 to assign 
Junction 5 as the outlet. Subcatchment 3 uses Junction 6 as its 
outlet. 



Add Rain Gage:

Hydrology > Rain Gages > 
Start Drawing 
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The cursor turns into a blue 
circle, indicating ‘Drawing 
Mode’ is active. 

Use a single-click to add the 
Rain Gage to the map display.  



Edit Rain Gage:

Hydrology > Rain Gages > 
Edit Rain Gage
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Select the Rain Gage by its ID (9 for this example) 
for attribute editing. 

The Time Interval should be changed to one hour 
(1:00).  Then select the default Series Name (2hr), 
which you will edit in the next step.

Make sure the Rain Format used is INTENSITY and 
the Rain Unit is IN (inches). 

Remember to Save before closing the Rain Gage 
Editor. 



Edit Time Series:

Time Series > Edit Time Series
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Select Edit from Edit Mode, then select 2Hr from 
the Time Series Name drop-down menu. 

This is the default Time Series that we will 
customize / edit for this example.
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Use the Delete button to remove the existing 
entries from the Time Series Table. Then use the 
Add New Row button to create 7 empty entries.

For each entry, use a date of 1/1/2002.  Then enter 
the following data pairs:

Time (H:M) Value
0:00 0
1:00 0.5
2:00 1.0
3:00 0.75
4:00 0.5
5:00 0.25
6:00 0

Click Save Record to save the changes, then close 
the Time Series Editor. 



Edit  Simulation Options

Options > Edit Options  

25

Make sure the Rainfall/Runoff and Flow Routing Process 
Models are checked / enabled. The Kinematic Wave Routing 
Model should be used.

Change the Infiltration Model to Modified Green Ampt, then 
click Save.
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Still within Simulation Options, navigate to the Dates tab, and 
use 1/1/2002 as the date for Start Analysis on, Start Reporting 
on, and End Analysis on. 

The Time (H:M) for Start Analysis and Start Reporting should 
be 12:00 AM.

The Time for End Analysis should be 12:00pm (12 hour 
simulation duration).
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Still within Simulation Options, navigate to the Time Steps tab 
tab, and use a Reporting Step of 5 minutes (0:05:00), and Dry 
Weather Runoff Step of 1 hour (1:00:00), and a Wet Weather 
Runoff Step of 15 minutes (0:15:00). 

The Time (H:M) for Start Analysis and Start Reporting should 
be 12:00 AM.

The Time for End Analysis should be 12:00pm (12-hour 
simulation duration).



Save Model:

File > Save Model  

Rim Simulation:

Project > Run Simulation 
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After the model is executed, the Status Window will 
appear. 

This window indicates if there were any errors found in 
the model, and if the process models are balanced 
(water coming in equals water going out), among other 
information, at different times. 



Visualize Results Across the 
Network:

Go to Browser Window:

View > Map Browser

Select Runoff as the Subcatchment Parameter.  

Select Head as the Node Parameter. 

Select Velocity as the Link Parameter

Select 01/01/2002 as the Date

Select ‘6:20:00’ as the Time. 

The map objects will then be color-coded based on 
the parameter values at 6 hours and 20 minutes of 
simulation. Note the legend that automatically 
appears.
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Visualize Results Along a Profile:
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Report > Graph > Profile

Double-click on Junction 4 in the map display, then 
click the + button next to Start Node. This makes 
Junction 4 the start Node of the profile.

Similarly, double-click on Junction 8 and click the + 
button next to End Node to make Junction 8 the 
End Node of the profile. 
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Click the ‘Flow Path’ button.  A profile path will 
automatically be generated along the flow path 
from the Start Node to the End Path. The path is 
indicated on the map display as a yellowish-orange 
line. 

The path is also listed in the Path List Format table 
(Node -> Link -> Node -> Link …).

Click on the ‘3D Profile’ button to launch the 3D 
profile plots (next slide).
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This slide shows the 3D visualization 
of the Pipe Network and 2D Water 
Profile along the selected path. 



Visualize Results in the Conduits 
at all Times:
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Report > Graph > Time Series

Select Link as the Object Type.

Select Flow as the Parameter.

Double-click on Conduit 1 in the map display, then 
click the + button next to add the conduit to the 
Feature ID list. Repeat for Conduit 2. 

Click the ‘Show Timeseries Plot’. 



Visualize Results in the Conduits 
at all Times:
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A plot will automatically be generated showuing
the flow results in Conduits 1 and 2 over the entire 
simulation duration. 



Saving the Model File:

User Account > View My 
Models

This opens a list (table) of previously 
executed models linked to your user 
account.

Click ‘Download Model’ to download 
an.inp (model input) file to your 
local machine’s Downloads folder. 

The .inp file can be uploaded back 
into MAGNET Pipe Network Analysis 
with:

File > Upload > INP
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Questions / Comments / Issues?

Use:  [Menu Bar] > Support > Contact Us 

Or directly email: 
support@magnet4water.com
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mailto:support@magnet4water.com

